Docker安装提示无供应商可供安装的解决办[linux教程]

Docker安装提示无供应商可供安装的解决办...
Docker安装提示无供应商可供安装的解决办

Docker安装提示无供应商可供安装的解决办[linux教程]

今天带来的是Docker安装提示无供应商可供安装的解决办法,首先我们定位到错误提示:问题: package docker-ce-3:19.03.11-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed。

Docker安装提示无供应商可供安装的解决办[linux教程]-盾给网络

根据提示,就是Docker安装过程中需要的依赖项containerd.io版本 >= 1.2.2-3,既然错误定位到,那么解决方法就油然而生了! 解决办法 进入阿里云镜像地址:https://mirrors.aliyun.com/docker-ce/linux/centos/7/x86_64/edge/Packages/找到我们想要的或者最新的containerd.io包!然后执行以下命令:

<code class="language-none">yum install -y https://mirrors.aliyun.com/docker-ce/linux/centos/7/x86_64/edge/Packages/containerd.io-1.2.<a href="https://www.ymkvip.com/tag/13" target="_blank">13</a>-3.1.el7.x86_64.rpm
</code>

Docker安装提示无供应商可供安装的解决办[linux教程]-盾给网络

安装完成后再执行以下命令即可:

<code class="language-none">yum install docker-ce docker-ce-cli containerd.io
</code>

 

站长教程

优优教程网四格引导_wordpress区块[wordpress美化教程]

2020-9-1 17:49:10

站长教程

会声会影使用时出现BurnStarR DLL已停止工作如何解决[windows教程]

2020-9-1 17:49:23

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索